centos更新nginx指定版本

centos更新nginx指定版本

April 141 2023-04-12

nginx好多洞洞洞洞啊

基线扫描又没过,需要更新nginx版本至1.22以上。yum update nginx 执行下来,更新到了1.24,也挺好,就是我没有1.24的ngx_http_cookie_flag_filter_module的包。

只能安装1.22

指定安装

https://nginx.org/packages/centos/7/x86_64/RPMS/

wget https://nginx.org/packages/centos/7/x86_64/RPMS/nginx-1.20.2-1.el7.ngx.x86_64.rpm
rpm -ivh nginx-1.22.0-1.el7.ngx.x86_64.rpm 

提示缺少依赖
image-1681290103362

安装依赖

yum install nginx-1:1.22.0-1.el7.ngx.x86_64

搞定


tmd, 当年学红帽都学狗身上去了,全还给老师了。
apt 玩的挺熟,yum怎么就玩的不行呢。我真是个菜鸡啊